Snom 300 Provisionierung

Ich weiss nicht, ob ich da im richtigen Forum bin, bin kein Informatik-Profi. Habe ein Snom 300 mit folgenden Systeminformationen:
Telefontyp: snom300-SIP
MAC-Adresse: 0004133439CA
Firmware-Version: snom300-SIP
Produktionsinformationen: Mac:0004133439CA;Version:Standard;Hardware:snom300 (H: R2A);Date:17/08/09;Copyright© snom technology AG
Laufzeit: 0 days, 0 hours, 6 minutes
LCS: 0 days, 0 hours, 6 minutes (exit 63 2001-12-24 00:00:21.513)
Freier Speicher: 488 K
CPU: 0.03 0.04 0.00 1/10 10
Bootloader-Version: 1.1.3-s
Erweiterungsmodul: (0)

Habe von Version 8.4. auf obige Version upgedated. Beim Neustart kam “prov. server failed”. Davor kamen 4 oder 5 attempts. Das Snom jedoch funktioniert. Muss ich da noch etwas machen?
Besten Dank,

Hallo Edomus,

hast Du für das Telefon schon mal auf Werkseinstellugen zurück gesetzt. Manchmal “verhakt” sich der Prov. Server. Auf Werkseinstellungen zurücksetzten kannst Du entweder am Telefon oder per MobyDick. Falls das nicht klappt müssten wir weiter debuggen.


Hallo Mathias

Danke vielmals - das hat’s gebracht…



Hallo Mathias

Jetzt habe ich aber das Problem, dass ich im Webinterface mit meinem Passwort nicht mehr rein komme…?

Ich hab’s mit meinem vorherigen, aber auch mit






Mit dem Administratorpasswort (ohne Nutzer) bin ich reingekommen und habe einen neuen Benutzernamen samt Passwort setzen können…


Hallo Edomus,

das geht auch einfacher: Du kannst in der Konfigurationsmaske für das jeweilige Telefon (“Endgeräte konfigurieren”) direkt den Zugang in den Feldern “HTTP-Benutzer” und “HTTP-Passwort” hinterlegen.
Nach einem reboot wird das dann an Dein Snom übertragen.

Auch das Admin-Passwort lässt sich für einzelne Telefone oder auch Systemweit setzen. Hierzu musst Du entweder unter Systemeinstellungen den Wert unter [LEFT]sys.peripherals.access.password [/LEFT]anpassen oder die Basiskonfiguration der Telefone verändern.



Good morning,

I don’t know if this is the correct thread where to ask about issues with snom 300 phone.

I’ve installed the Mobydick 7.0 test version which is suitable only for up to 6 clients. At the moment I have only two clients which are connected to the network. A softphone whose configuration is a basic one generated or configured manually. As a second client, I have a snom 300. I have installed a dhcp server on the same Mobydick machine and each device fetches its own IP Address. But when I add a new snom device with its respective MAC Address, the provisioning doesn’t work.

When I apply the changes on the mobydick web front-end, there’s always an error saying that the phone couldn’t be rebooted due to an unknown IP Address.

If I go to the Provisioning Log Tab from the device settings on the mobydick web front-end, I get the following entry:

Logfile /var/log/mobydick/provisioning/MACXXXXX.log
(no data in /var/log/mobydick/provisioning/MACXXXXX.log)

It would be great if you can suggest me some possible solutions which I can try to implement in order to make this work.

Thank you very much in advance.

Hello cgmarin,

I have installed a dhcp server on the same Mobydick machine and each device fetches its own IP Address.

What excatly do you mean with this sentence? Our MobyDick is already shipped with a DHCP-Server which can be configured using our web interface. (Go to Appliance -> Services)

If you configure that server correctly it should not be necessary to add the snom phone manually, instead you just reset the snom to factory settings, plug it in to your (phone)network and the it appears in the device list. From then on it has a IP address known to MobyDick and can be provisioned.

Another way:
If you want to configure your own dhcp, make sure that your DHCP sends the following option 66:{mac} needs to be changed the corresponding IP of your MobyDick server.

Best regards,

Hello Jan,

Thank you very much for your answer. I didn’t notice it before, since all the documentation is in German, and it is not that good yet. But I’m still working hard on it :slight_smile:

I have another question concerning the Voicemail. I’ve seen that there’s a voicemail preconfigured whose extension is *104. But when I call someone after a few seconds the call drops without forwarding it to the Voicemail. How do I activate this or better where can I check this configuration?

Thank you very much in advance.

Best regards,


Hello Carlos,

yeah, i know that the documentation is less than stellar, but we are working hard to improve it. Also we are working on an english translation, but this will take some time.

To activate your voicemailbox you need to define an action on your user. An action is a powerful concept which can do different things with a call before or after it rings on some phone. E. g. an action is “Transfer to voicemailbox”

For a simple example, go to “Users -> Userlist” select a User and click edit.

In form you will notice 4 Tabs on the right “Internal/Before”, “Internal/After”, “External/Before” and “External/After”.
If you want to drop all calls coming from your trunk (External calls) to your voicemailbox, you need to go to “External/After” and use “Add” -> “Voicemailbox” to define the voicemailbox-action for this user.
For internal calls, the right tab is “Internal/After”.
Then you click on save, apply telephony configuration and it should just work.

But you don’t need to do this for each and every user. You can also use the predined action template (Located in: “Advanced”->“Action templates”) for voicemailboxes and just assign that to all your users. This has the same consequences as doing the steps described above, with the difference that changes to that template immediately are applied to all users assigned to the template.

Just select the voicemailbox-template and click on “Assign”, then select the “Destinations”-Tab and select the users you want to assign it to. You maybe want to do that twice, with call origin external and internal, so that it applies for all calls. Then just apply telephony configuration, and it should just work.

Best regards,

Hello Jan,

Thanks a lot for your reply. I have already configured the voicemail and it works perfectly.

There are just a couple of questions more that I would like to ask and I know that this is not the correct thread to talk about these topics. If I should start a new thread regarding these, please let me know.

  1. The voicemail works perfect. However, we don’t only use snom phones but also Linksys phones. I was just wondering if there’s any possibility to change the voicemail number, since somehow after dialing *10 (not even the complete *100), the Linksys phones won’t place the call, showing a message on their screen like “Declined” instead. I’ve been checking the possibility to edit the values from the asterisk config files by going to “Appliance -> System Settings”. But if any value is changed, it will be applied only in the context “general” from sip.conf, for example.

  2. I’ve seen also a TFTP option in the services tab. I’ve already enabled it, but I can’t find a way to configure this, not even on the Mobydick shell. Is there any way to set up our own TFTP server on the same machine?

Thank you very much again for your support.

Hello Jan,

I’ve found an answer for the first question. Thank you anyway :wink:

Hi cgmarin,

we use dnsmasq’s tftp server. When you turn it on it’ll use /var/www/mobydickcmd/firmware as its tftproot.
Just put your files into this folder and your devices should be able to fetch them. At this time there is no web-ui to upload/download files for custom devices.

You can try reuse (or abuse :p) our firmware-ui (see devices - firmware in the menu) to manage your own files. Uploaded Files will go into /var/www/mobydickcmd/firmware/pool/ but will be renamed to our internal Database ID.