M700 DECT base station and Mobydick

Hello All,

I have successfully integrated 4 M700 base stations into our Mobydick system here. They are configured in multi-cell mode and we are using M65 phones. I followed the instructions here: https://www.pascom.net/doc/en/endpoints/snom-dect/
It mostly works fine. However, there are a number of problems for which I haven’t been able to find a solution to:

  1. Many settings which I can see Mobydick provision via http://<server>/provisioning/<mac address>/settings are not set on the M700 when I login to the web administration for the the device. For example, the LDAP server address is missing as well as the configuration server address. I can add them manually to the M700 but even when I do this, I still see some settings from provisioning are not set on the M700.
  2. With the default LDAP filter “(|(cn=%)(sn=%))” which Mobydick sets, it isn’t possible to search the LDAP phone book on an SNOM M65 phone. I work around this by loging onto the web based administration page for the M700 currently acting as master and remove the setting “ldap search filter”. Then the phone book works again.
  3. Time zone is not set on the M700. I can see that via the provisioning URL on the Mobydick server, the timezone is set to “CHE+1” (which if it is for Switzerland then this is correct). But on the M65 phone the time is wrong (it is 1 hour behind). I can set this manually on the M700 directly.
  4. Finally, and I don’t know if this is more of a SNOM problem or a Mobydick problem, but when the M700 reboots, all the settings I added manually are removed and the defaults are restored. Perhaps this is a result of provisioning i.e. prior to provisioning the devicevia mobydick, the defaults are first installed over my settings and then as a second step, the settings from Mobydick provisioning are then applied. It is not super convenient because each time I add a new M65 to the system, the base stations reboot, and I must apply all the above mentioned work arounds again.

is there a solution to these problems? We currently have version 7.11 of Mobydick and the M700 is running version 03.24B12 which is apparently the latest stable version from SNOM.


Hello Aaron,

first: Welcome to our forums!

Now to your questions:
1.) That should “just work”. I will file a bug ticket for this, and we will take a closer look

2.) That’s on purpose this way, You need to set a Firstname and a Lastname in the mobydick phonebook to search the ldap. If you remove the search filter, you can easily run into memory problems when using large phonebooks with an M700 (Even with the filter in place, the current m700 has a bug where it crashes with more than ~1100 Entries. Unfortunately, we can’t do anything about it but wait for a bugfixed firmware from snom)

3.) Is CHE+1 the first entry in the list? This also could be related to issue #1, so same answer here, we will take a look.

4.) That happens because the m700 requests configuration information from mobydick on boot and overrides it’s own configuration with that information - So it’s not a bug, it’s a feature :wink:


Thanks for the speedy reply! :slight_smile:

Understood. So I checked the phonebook and all of the users in Mobydick have frist name and last name filled in under the “phonebook” tab of the user settings. If I put the default LDAP filter back and try to browse the central directory (LDAP phonebook) from the M65 phone, I get a message which says “The list is empty”. It isn’t possible to search the phonebook anymore.

Not sure which list you mean. There are two relevant lists (or drop down boxes) on the M700 user interface. The first is for country (but it is only relevant if “Set timezone by country/region” is enabled). Here the M700 defaults to “United Kingdom” with “Australia” being the first in the list. The second drop down for timezone itself. The first entry is “-12:00”. I didn’t find any such list on the Mobydick side. Sorry if I misunderstood :frowning:

Here is what Mobydick sends though when provisioning:

country_code&: 0044
date_us_format&: off
time_24_format&: on
timezone&: CHE+1
tone_scheme&: GBR

Please let me know if I can provide any assistance or information for finding the bug in point 1.

Thanks for the information. This seems a bit odd. The provisioning data for the m700 should look like XML. Which exact version of mobydick are you using? Are the m700 base stations listed within the “Gateway list” menu?

The version of Mobydick version is 7.11.02.

The M700 devices appeared automatically in the Gateway list (which i thought was rather nice :slight_smile: ). However, what I do notice is that the M700 which is currently performing the role of “master” in the multi-cell configuration is not the same device that I set to be master in the mobydick configuration. I just assumed that because the configured master rebooted one time that the current master took over the role of master. Not sure if that influences anything here.

You may want to try to update to the newest 7.11. Version (7.11.05 as of this writing), there are some M700 Bugfixes in the newer Releases. However, I’m not sure if this will resolve your issues.

I just assumed that because the configured master rebooted one time that the current master took over the role of master. Not sure if that influences anything here.

That’s an insteresting detail. We will look into this more thorougly.

So I have now upgraded to 7.11.05 but so far the experience is more or less the same as before. I have the impression that the M700 isn’t a stable device. If I make too many changes on the device it self, it reboots and all my changes are lost. Or pressing save has no effect i.e. the new settings are immediately forgotten, not saved. Maybe this problem also prevents the settings that Mobydick send as part of provisioning from being saved? Maybe this whole problem is solved by a firmware update from SNOM? I would be interested to know if the current release candidate firmware from SNOM (which at the time of writing is V355B19) would solve these issues. Sadly, I can’t test this without taking some M700 out of productive use (which would not amuse our users).

Thats a pity. I noted all the Information you gave me into the Bugticket and we will take a closer look at the issue.

But I can give you a few more hints:

  • At our office, we’re also using an M700 system together with a beta version of the upcoming mobydick 7.13, so far it seems to work. However, we don’t use LDAP-Phonebooks on these devices and I agree with you that the Web Interfaces has a REALLY bad usability.
  • If you Upgrade a base station from 3.24 to 3.55, you cannot downgrade anymore, we have confirmed this with snom, because one of our test devices was upgraded “by accident”. As far as I know, you also need to have the same firmware version on all stations to be able to use multi-cell.



we discussed your Issues. Please open a support ticket if you have a commercial license (see https://www.pascom.net/en/customer-support/) and mention to this community thread. This would make debugging the issues you experience much easier.


So just to conclude this thread I should summarise what I have learned with the help of support. I could get the correct timezone and language on the M65 handsets by setting the value “LANG=de_DE.UTF-8” in the file /etc/default/locale. Upgrading to version 7.11.05 of Mobydick solved the address book problems on the M65. I now have undesirable behaviour from the M65 but these are SNOM issues rather than Mobydick related.