Fehler beim Update Paket md-branding-community

Hi,

beim Update ist folgender Fehler aufgetreten.



Reading package lists...
Building dependency tree...
The following packages will be upgraded:
  md-branding-community
1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 0B/43.3kB of archives.
After unpacking 0B of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  md-branding-community
debconf: delaying package configuration, since apt-utils is not installed
(Reading database ... 
dpkg: serious warning: files list file for package `fw-blocker' missing, assuming package has no files currently installed.
36932 files and directories currently installed.)
Preparing to replace md-branding-community 1.01.01.R (using .../md-branding-community_1.02.00.R_all.deb) ...
Unpacking replacement md-branding-community ...
dpkg: error processing /var/cache/apt/archives/md-branding-community_1.02.00.R_all.deb (--unpack):
 trying to overwrite `/var/www/mobydickcmd/nbproject/project.xml', which is also in package md-webservice
Postinst von /var/lib/dpkg/info/md-branding-community.postinst Modus abort-upgrade Revision 1.01.01.R
Preparing apache2 restart



Errors were encountered while processing:
 /var/cache/apt/archives/md-branding-community_1.02.00.R_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Gruss

Flo

Hallo Florian,

danke für die Info. Kannst Du mit dem System noch arbeiten?
Wir werden das Problem erst in der 6.12.01 beheben können.

Gruß,

Thomas

/var/www/mobydickcmd/nbproject/project.xml wird offensichtlich sowohl von md-webservice als auch von md-branding-community bereitgestellt, da hat der Pakettierer nicht aufgepasst. Angenommen, die bestehende Datei (aus md-webservice) ist weniger wichtig, kann man die entsprechende Zeile manuell aus der Liste /var/lib/dpkg/info/md-webservice.list entfernen und das Update wiederholen.

Das ist ein schmutziger Hack und kann weitere Folgeschaeden haben, vielleicht kann ein Entwickler sich zu diesem Vorschlag aeussern.

Hallo,

wir haben die entsprechenden Pakete bereits geändert, werden diese aber erst mit der 6.12.01 ausrollen (voraussichtlich in der nächsten Woche).

Gruß,

Thomas