Softphone does not work correctly if the audio device name contains an Umlaut (MD-9766)

If the device name of an audio device contains an Umlaut (e. g. “Kopfhörer”), the device name is not displayed correctly within the client - instead of the umlaut a ? Sign is shown.

Additionally, phoning often does not work correctly.

Reported by @SirRichard in this thread.

I can add that now the Jabra headset started not working for me as well. Not only for my colleague. So it seems to be an issue with Jabra, Win10 or the new client.

@SirRichard Did you try the newest beta version (at least 17.01.D110)? It contains some fixes for softphones, probably it helps here.

Yes, thanks. Tried it, worked after install but some hours later it didn’t. I locked my screen in the lunch break but didn’t do anything out of the ordinary in between.

When I accept the call I makes shortly after a kind-of-negative-sounding “beep”. But it seems to be only affecting the headphones. The mic was working.

I restarted the app, then it worked again.

Hope this helps.

@SirRichard does this issue still exist when using the newest 17.03 BETA?

@jlorenz Sorry, still not working!

2 posts were split to a new topic: No audio on outgoing calls

Hi @jlorenz,

the issue that the headset is not working after I lock the screen (the only pattern I can think of) still persists. Super annoying because if I don’t restart the phone app after lunch break and I take a call the caller can hear me but I don’t hear anything.

Any ideas or new versions coming up?


PS: I saw the 17.4 version on your download page. I give it a shot. But did anybody address my issue?