Phone ringing when calling someone

Hi there,

I think I experience a really annonying bug.

When I call someone the phone makes the regular beeping/waiting sound in the headphones (good) but IN ADDITION making a phone-ringing sound like somebody is calling me(!) (bad).

Obviously the ringing is set to regular speakers, else I wouldnt be able to hear if somebody calls me.

Is there a way to disable the ringing when calling someone or is this really a bug?

Thx in advance


are you running two client instances on your machine?
What happens if you use a hardware phone to dial the same target number?
What happens if you dial the same target number from another desktop client (on a second machine)?



Hi Thomas,

no, just one version of the new Pascom client (not the one that looks like 1995).

The ringing sound is the same as when somebody calls me - so it has to be sent by the client.

All my colleagues use the same client and they all experience the same issue. So I guess it’s a general problem.


PS: Sorry, forgot the details. I’m on Win10 64bit.

Do you use a Jabra Headset?
I have the same Problem using a Jabra Pro 9450.
The Basestation is ringing when i’m calling a number with the Client.

Yes, actually we are!

This is a very interesting hint. Jabra (and also Plantronics) require us to signalize a in- or outbound call to the headset controller. Maybe something is wrong if the Headset has a built in ringer.

I will file a bug into our tracker. Thank you.

There’s also a bug with calls put on Hold.
It’s described here in german: Halten und Gespräch fortsetzen

Regarding the ringer: do you guys think that we should continue to use the basestation ringtone for inbound calls?

At the moment you should hear two ring tones: one from the pascom client using your pc speaker and another one from your headset base station. Of course we can fix the bug by suppressing the base station ringtone on an outbound call. Alternatively we could disable it completely.

What is your opinion?


sorry for the late reply, was on vacation!

I think I just hear one ringtone. But maybe just go with the ringtone your software is emitting, then you have full control over the behavior?


Ok, I validated it! You were right after all - the Jabra station is ringing, not your software!

So I think if you’d disable the ringing in the Jabra, we should be fine for outgoing calls.



thank you for the feedback.

We’re working on this issue already.
Some parts are fixed in the recently released version 16.01, others will be fixed soon in 17.00.



Awesome! Could you provide a link when v17 is ready to use? Your website still delivers v16.00.


I just found your post for downloading v16.01: Beta Version pascom Client 16.01

Good thing is: the Jabra station is not ringing anymore. Unfortunately I don’t get any acoustic feedback when calling someone. I’d expect the beep-beep-beep-sound so I know that it’s actually doing anything.

If this would be included in v17, I’m super happy :slight_smile: