Nach update von 7.06.03 auf 07.07.02 no-way audio und Transconding Fehlermeldungen

Hallo zusammen,

nachdem ich gestern manuell von 7.06.03 auf 7.07.02 umgestiegen bin habe ich das problem das ich no-way Audio bekomme wenn ich im setup meiner Endgeräte G.722 aktiviert habe.


disallow=all
allow=g722
allow=alaw
allow=ulaw
allow=g729

Auf meinen Ämtern ist G.722 konfiguriert.

Offenbar haut das Transcoding nicht hin, denn ich bekomme folgende Fehlermeldungen:

[Jul 26 21:44:41] WARNING[2733][C-00000000]: channel.c:5309 set_format: Unable to find a codec translation path from (alaw) to (g722)
[Jul 26 21:44:41] WARNING[2733][C-00000000]: chan_sip.c:7291 sip_write: Asked to transmit frame type ulaw, while native formats is (g722|h264) read/write = ulaw/ulaw
[Jul 26 21:44:41] WARNING[2733][C-00000000]: channel.c:5081 ast_write: Codec mismatch on channel SIP/mdc_trunk_conf-5-00000001 setting write format to g722 from ulaw native formats (alaw)
[Jul 26 21:44:41] WARNING[2733][C-00000000]: channel.c:5309 set_format: Unable to find a codec translation path from (alaw) to (g722)
[Jul 26 21:44:41] WARNING[2733][C-00000000]: chan_sip.c:7291 sip_write: Asked to transmit frame type ulaw, while native formats is (g722|h264) read/write = ulaw/ulaw
[Jul 26 21:44:41] WARNING[2733][C-00000000]: chan_sip.c:7291 sip_write: Asked to transmit frame type ulaw, while native formats is (g722|h264) read/write = ulaw/ulaw
[Jul 26 21:44:41] WARNING[2733][C-00000000]: chan_sip.c:7291 sip_write: Asked to transmit frame type ulaw, while native formats is (g722|h264) read/write = ulaw/ulaw

Ein “core show translation” zeigt folgendes:

IPPBX*CLI> core show translation 
         Translation times between formats (in microseconds) for one second of data
          Source Format (Rows) Destination Format (Columns)

            gsm  ulaw  alaw  slin testlaw
      gsm     - 15000 15000  9000   15000
     ulaw 15000     -  9150  9000   15000
     alaw 15000  9150     -  9000   15000
     slin  6000  6000  6000     -    6000
  testlaw 15000 15000 15000  9000       -
IPPBX*CLI> 

Sieht so aus als könne MD zwischen alaw und g722 transcoden.

Woran kann das liegen, und warum ging es in 7.06.03?

Viele Grüße,
Nik

Guten Morgen,

wenn du g722 verwenden möchtest, muss das entsprechende Modul geladen werden. Das kannst du über die Systemeinstellung sys.asterisk.modules.codec_g722.noload=0 tun. Bei den SIP peers dann ebenfalls den Codec noch erlauben. Danach noch Erweiterungskarten/Telefonie neu laden.
Das sollte es gewesen sein.

Grüße
Markus

Guten Morgen Markus,

die Einstellungen habe ich bereits vorgenommen.

Siehe Screenshots:

Auch nach dem Telefonie laden bzw. reboot was das Problem noch immer da.

Was mich wundert ist das die Translationliste so leer ist. Muss man die translations irgendwo konfigurieren?

Viele Grüße,
Nik

Attachments


Guten Morgen Markus,

die Einstellungen habe ich bereits vorgenommen.

Siehe Screenshots:



Auch nach dem Telefonie laden bzw. reboot was das Problem noch immer da.

Was mich wundert ist das die Translationliste so leer ist. Muss man die translations irgendwo konfigurieren?

Viele Grüße,
Nik

Hallo Nik,

überprüfe doch bitte per module show like g722 in der CLI ob das Modul auch geladen ist. Wenn ja sollte die Ausgabe so aussehen

Module Description Use Count
codec_g722.so ITU G.722-64kbps G722 Transcoder 0
1 modules loaded

Dann sollte dies auch über CLI core show translation auftauchen

        gsm  ulaw  alaw  slin  g722 slin16 testlaw
  gsm     - 15000 15000  9000 17250  26250   15000
 ulaw 15000     -  9150  9000 17250  26250   15000
 alaw 15000  9150     -  9000 17250  26250   15000
 slin  6000  6000  6000     -  8250  17250    6000
 g722 15600 15600 15600  9600     -   9000   15600

slin16 21600 21600 21600 15600 6000 - 21600
testlaw 15000 15000 15000 9000 17250 26250 -

Du musst Erweiterungskarten anwenden durchführen!

Was soll ich sagen, Markus, Du hast wiedermal den entschiedenen Hinweis geschrieben. Jetzt funktioniert es.

Danke!

Viele Grüße,
Nik

Re,

schön, wenn es nun klappt!

Grüße
Markus