Fehler nach Update auf 7.13.00R

Hallo zusammen,

nach dem Update auf Version 7.13.00R gibt mir Icinga folgende Fehlermeldung:

database query ERROR: FATAL: password authentication failed for user “mobydickcmd”

Ist hier etwas bekannt bzw. gibt es einen Workaround um das Problem zu beheben?

Danke im Voraus

Hallo W7T2A,

erstmal: Willkommen im Forum!

Von welcher Version aus hast du aktualisiert? - Es gibt hier ein bekanntes Problem mit dem escaping des DB-Passwortes in der Icinga Konfiguration. Abgesehen davon, dass der Check fehlschlägt, hat das weiter keine Auswirkung.

Funktioniert sonst alles?

Grüße,
Jan

Hallo jlorenz,

danke für die Antwort - Ausgangsversion war 7.12.03R
Bisher funktioniert jedenfalls mal die Telefonie ohne Probleme.

Hallo W7T2A,

kannst Du bitte noch folgendes checken:

grep postgres /etc/icinga/md-conf.d/commands.cfg

Das Problem ist der Teil bei “-dbpass”, kommt darin ggf. ein at-Zeichen (@) vor?

Danke fürs mithelfen!
Gruß,

Thomas

Hallo Thomas,

ein @ ist im dbpass Parameter nicht enthalten

Viele Grüße

Hmm. Was ist denn ansonsten an ungewöhnlichen Zeichen (ausser Buchstaben, Zahlen) in diesem Passwort enthalten?

Als Sonderzeichen kommen noch “-” und “,” (2x hintereinander) vor

Ok, Danke für die Info.

Hallo,

Gleiches Problem, nur ein “,” als Sonderzeichen enthalten.

Update von 7.12.03

Gruß
Tobias

Hallo Tobias,

Danke für die Info.

Gruß,

Thomas

Hallo Thomas

Gleiches Problem, als Sonderzeichen sind " _ , +" enthalten.

Update von 7.12.01 CE

Grüße

Maik

Hallo zusammen,

Okay, da das Problem häufiger auftritt als gedacht hier nochmal eine kurze Klarstellung: Es ist rein kosmetisch, d. h. nur der Icinga Check schlägt aufgrund von Escaping-Problemen fehl. Der Rest des Systems funktioniert weiterhin! Nichtsdestotrotz arbeiten wir an einer Lösung.

Grüße,
Jan

Hallo,

…bei uns auch. Sonderzeichen sind “-” und “,”
Update von 7.12.02 auf 7.12.04

Update MD Nr. 2 von 7.12.01 auf 7.12.04 - keine Meldung in Incinga.
In dem String an dieser Machine sich aber auch keine Sonderzeichen drin. Nur Buchstaben u. Zahlen.

Happy troubleshooting…

cu
Christoph

Hallo,

in 7.12.04 wurde das Problem schon angegangen.
Die nächste Woche erscheinende 7.13.01 bringt diesen Bugfix dann auch in die 7.13.x Linie mit ein.

Danke fürs Mithelfen!

Gruß,

Thomas

Sorry, nochmal details zu der Sache.
In 7.12.04 scheint es noch immer Probleme mit dem “,” zu geben, in 7.13.01 und 7.12.05 wird es endlich erledigt sein :rolleyes: