CRITICAL: xmppd_5223 Connection refused / nach Import der Einstellungen

Hallo,

ich habe ausgiebig auf einer 7.10.2 Community Edition getestet und nun eine Mobydick gekauft.

Auf der lizensierten MD (7.10.3) hab ich nun der Einstellungen meiner Test MD (7.10.2) importiert.

So weit so gut nun bekomme ich aber “CRITICAL: xmppd_5223 Connection refused” im Monitoring.

Hat wohl was mit der SSL Verbindung zum xmpp zu tun.

Kann mir da bitte jemand weiter helfen?

Danke Philipp

Hallo Philipp,

den xmppserver hast Du wohl schon mal über das Anwenden-Menü neu gestartet?
Ein asterisk 1.2.x ist ganz schön antik :slight_smile:

Gruß,

Thomas

Hallo Thomas,

ich hab die ganze Box neu gestartet.

Laut netstat “horcht” xmpp gar nicht auf den Port.


root@mobydick:~# netstat -anp | grep 2054
tcp6       0      0 :::7070                 :::*                    LISTEN      2054/java
tcp6       0      0 :::7777                 :::*                    LISTEN      2054/java
tcp6       0      0 :::9090                 :::*                    LISTEN      2054/java
tcp6       0      0 :::9091                 :::*                    LISTEN      2054/java
tcp6       0      0 :::5222                 :::*                    LISTEN      2054/java
tcp6       0      0 :::5229                 :::*                    LISTEN      2054/java
tcp6       0      0 :::7443                 :::*                    LISTEN      2054/java
tcp6       0      0 :::5269                 :::*                    LISTEN      2054/java
tcp6       0      0 :::5275                 :::*                    LISTEN      2054/java
tcp6       0      0 127.0.0.1:5275          127.0.0.1:44857         VERBUNDEN   2054/java

ja der 1.2 ist ziemlich antik - drum beschäftige ich mich ja schon einige zeit mit mobydick.

Also da muss ich euch mal eine Gratulation aussprechen - wirklich gelungenes Produkt.
Hab mir einige “Konkurenzprodukte” angesehen, aber gerade in Bezug auf Funktionalität und gerade die Anpassbarkeit mit dem Flexpanel (und das bei dem Preis) - echt konkurenzlos…

Danke

Guten Morgen Philipp,

die Box neu starten und xmppserver per “Anwenden” neu starten verhalten sich recht unterschiedlich.
Über das Anwenden-Menü wird zusätzlich die Konfiguration des xmppservers geprüft und ggf. gerade gezogen, dies passiert bei einem reboot oder Neustart über die shell nicht.

Danke für das Lob!

Gruß,

Thomas

Hallo,

auch das neustarten dex xmpp hat nichts gebracht.

Danke

Seltsam. Kannst Du mir bitte das Log des Neustart-Jobs hier posten?
Ggf. versuchst Du dich auch mal am openfire unter port 9090 anzumelden. Da sollte direkt unter “Server information” etwas über den Port stehen.

Hallo,

ich hab mir die “Server Information” angesehen - da waren die Ports gelistet, aber nicht der 5223. Unter “Edit Server Properties” war “SSL Enabled:” auf “disabled” - das hab ich geändert und nun funktioniert es.

Danke

Kannst Du bitte trotzdem das Job-Log vom xmppserver Neustart posten?
Irgendetwas ist da nicht in Ordnung, ich will nur “Langzeitschäden” vermeiden :confused:

Hallo,

meinst du das hier:


2015-10-08 08:34:06	sql: Connecting to database
2015-10-08 08:34:07	tsk050309: Starte Task 050309 'XMPP Server neu starten', Parameter: [restart], User-ID: [1]
2015-10-08 08:34:07	Setze XMPP Domain auf [mobydick]
2015-10-08 08:34:09	Setze XMPP Admin auf [admin]
2015-10-08 08:34:09	Setze externalip auf [10.0.2.207]
2015-10-08 08:34:09	Setze JavaOptions auf -Xmx336M]
2015-10-08 08:34:09	. Starte [/etc/init.d/xmppd stop]
2015-10-08 08:34:10	... Stopping xmppd: Stopping jitsi videobridge: jitsi videobridge.
2015-10-08 08:34:10	... xmppd.
2015-10-08 08:34:10	. Exit: [0]
2015-10-08 08:34:10	Warte 5 sekunden...
2015-10-08 08:34:15	. Starte [/etc/init.d/xmppd start]
2015-10-08 08:35:06	... Starting xmppd: Delete plugin cache: mdarchive mobydick search.
2015-10-08 08:35:06	... Clean pubsub cache: OK.
2015-10-08 08:35:06	... xmppd.
2015-10-08 08:35:06	... Starting jitsi videobridge in background
2015-10-08 08:35:06	. Exit: [0]
2015-10-08 08:35:08	XMPPD restart durchgeführt

Hallo,

ja, sieht soweit gut aus.
Belassen wir es bei einem ominösen Zufall?

Gruß,

Thomas

Ja,

passt.

Danke