Bildschirm nach Appliance-Installation schwarz

Hallo zusammen,

ich wollte heute die MobyDick-Installation auf einem Intel Desktop Board D2500CC ausprobieren, da dieses alle Vorraussetzungen für die MobyDick mitbringt. Einen ATOM, zwei NICs und max. 4 GB RAM. Das ganze in Verbindung mit einer 30GB-SSD sollte ja eigentlich super sein. Eigentlich.

Ich habe die 07.06.01 per DVD installiert und die Appliance wird auch vollständig auf das System kopiert. Nach dem Abschluss des Kopiervorgangs und dem Starten des Systems geht aber der Bildschirm aus und bleibt dunkel. Ein Neustart mit Strg-Alt-Entf klappt zwar, nach den ersten Boot-Zeilen wird der Bildschirm aber wieder dunkel :(. Als letzte Zeile ist die folgende zu erkennen:

Waiting for /dev to be fully populated ...

Scheinbar fährt das System auch nicht weiter hoch, da ich im DHCP-Server auch kein IP-Adress-Release sehen kann.

Da MobyDick auf Debian Squeeze basiert, habe ich zum Testen mal Debian 6.0.6 netinstall installiert. Das funktioniert super. Nach der Installation habe ich eine normale Konsole zur Verfügung.

Hat jemand einen Tipp für mich, wie ich die MobyDick auf der Hardware zum Laufen bekomme?

Danke
Ulf

Hallo Ulf,

Soweit ich weiß ist diese Board oder im speziellen der SATA Chipsatz nicht unterstützt von der MobyDick.

Im Installer scheint der Treiber noch dabei zu sein aber im Bootimage dann nicht mehr so das die MobyDick die Root Partition nicht finden kann.

Ich habe von beroNet die alte Appliance und die hat auch ein Mainboard von Intel mit dem Chipsatz und dort geht es auch nicht.

Witziger weiße hat es bis zur 7.4 oder so noch funktioniert.

Gruß Markus

Hallo Markus,

da hab ich wohl mal so richtig daneben gegriffen :(. Danke für die Info. Weißt Du, ob es eine Übersicht übr die unterstützten Chipsätze gibt?

Danke
Ulf

Nee keine Ahnung @Pascom das wäre doch mal ne Idee eine HCL zu Posten.

@Ulf genau das Problem hatte ich vor ein paar Wochen habe das die Appliance Upgedatet und danach hat Sie nicht mehr gebootet.

Danke.

Hast Du evtl einen Tipp für ein Mini-ITX-Board mit zwei NICs?

Dann versuch ich morgen mal, ob die Installation auch auf einen angeschlossenen USB-Stick funktioniert.

Leider nicht habe bis jetzt nur die SlimLine von Pascom und Installationen auf VMWare gemacht

Danke Markus.

@Pascom: Seht Ihr bei dem Gigabyte-Board GA-C1037UN die Chance, dass die Chips unterstützt werden?

Danke
Ulf

Ich habe es jetzt noch einmal mit der USB-Installation versucht, aber diese ist erwartungsgemäß auch gescheitert, da die USB-Geräte ja auch als /dev/sdX eingebunden werden und damit von dem nicht unterstützten SATA-Chip abhängen.

@Pascom: Gibt es von Euch wieder eine Appliance, wie es in Eurem Wiki aufgeführt ist? Wenn nicht, gibt es irgendwelche Regeln, nach denen ich Hardware-Chips auswählen kann, die von MobyDick unterstützt werden?

DAnke
Ulf

Hallo Ulf,

wenn du einen Server in der Leistungsklasse der Appliance haben möchtest, kannst du die Slimline-Mobydick kaufen.

Zur HCL:
Das können wir leider nicht machen, Aufbau und Pflege dieser Liste ist ein viel zu großer Aufwand für Hardware die wir offiziell ohnehin nicht Supporten können. Insofern bleibt euch da leider nur ausprobieren übrig… Was man ja mit einer VM jederzeit machen kann. Für was willst du denn die Hardware genau verwenden?

Grüße,
Jan

Hallo Jan,

danke für die Infos. Es ging mir hauptsächlich um den Formfaktor eines Systems, dass man notfalls auch auf den Schreibtisch stellen kann. Da inzwischen immer mehr Telefonanschlüsse auf IP umgestellt werden, bräuchte man dann ja auch kein Gateway mehr. Deswegen der Test mit dem Mini-ITX-Boards, da diese auch die entsprechende Power für das MobyDick-System hätten ohne Lüfter verbaut zu haben (wie die Slimline).

Ich will im ersten Step jetzt mal ein Testsystem für mich aufbauen und wollte dabei gleich nach einen System suchen, dass Eurer Appliance gleich kommt. Leider gibt es die ja nicht mehr :(. Um so mehr hatte ich mich gewundert, dass sie in der 7.6 Wiki immer noch als System aufgeführt ist. Mein Virtualisierungsserver läuft nicht ständig, so dass mir auch eine VM da nicht weitergeholfen hätte.

Dann versuche ich mal noch einen kompatiblen Chip zu finden. Ich bin für jeden Denkanstoß und Hinweis dabei dankbar.

Danke
Ulf

Hallo Ulf,

die “alte” Appliance ist noch aus Dokumentationsgründen online, da die aktuelle MobyDick7 ja auf dieser Hardware betrieben werden kann. Auf den Schreibtisch stellen würde ich mir das ding allerdings nicht, da es auch aktiv belüftet ist.

Melde dich bitte mal bei unserem Vertrieb unter (+49 991 29691 - 200), evtl. haben wir da etwas für dich.

Grüße,
Jan

Hallo Markus,

ich hab das Thema ja immer noch nicht aufgegeben. Du hast ja geschrieben hast, dass der SATA-Chip nicht unterstützt wird. Weißt Du, ob es sich nur auf den im “Intel Desktop Board D2500CC” verbauten NM10 bezieht oder die auch andere der NM-Reihe? Ich habe jetzt noch einen Fertig-PC gefunden, der einen NM70-Chip hat und die restlichen Ausstattungsmerkmale, die für eine MobyDick passen.

Danke
Ulf

Hallo Ulf,

Nein weiß ich nicht aber man könnte ja mal schauen welche KerbeljModule mitgeliefert werden anhand dessen sollte man ja drauf schließen können welche Board theoretisch funktionieren könnten

Gruß Markus

Hallo Markus,

danke für Info. Ich habe jetzt mal gesucht, aber über die Internetsuche auch nicht wirklich eine Antwort auf die Frage, welche Kernel-Module für den NM70-Chip benötigt werden. Über den Vergleich MobyDick auf einer Slimline und Debian auf dem Board mit NM10-Chip konnte ich auch nichts finden. Beide benutzen im IDE-Modus den Kernel-Treiber ata_piix:
MobyDick Slimline:

root@mobydick:~# lspci -s 00:1f.2 -vvv
00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller (rev 02) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Super Micro Computer Inc Device 060a
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- < PERR- INTx-
        Latency: 0
        Interrupt: pin B routed to IRQ 19
        Region 0: I/O ports at ac00 [size=8]
        Region 1: I/O ports at a880 [size=4]
        Region 2: I/O ports at a800 [size=8]
        Region 3: I/O ports at a480 [size=4]
        Region 4: I/O ports at a400 [size=16]
        Region 5: I/O ports at a080 [size=16]
        Capabilities: [70] Power Management version 3
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [b0] PCI Advanced Features
                AFCap: TP+ FLR+
                AFCtrl: FLR-
                AFStatus: TP-
        Kernel driver in use: ata_piix

root@mobydick:~# lspci -s 00:1f.5 -vvv
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02) (prog-if 85 [Master SecO PriO])
        Subsystem: Super Micro Computer Inc Device 060a
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- < PERR- INTx-
        Latency: 0
        Interrupt: pin B routed to IRQ 19
        Region 0: I/O ports at 9c00 [size=8]
        Region 1: I/O ports at 9880 [size=4]
        Region 2: I/O ports at 9800 [size=8]
        Region 3: I/O ports at 9480 [size=4]
        Region 4: I/O ports at 9400 [size=16]
        Region 5: I/O ports at 9080 [size=16]
        Capabilities: [70] Power Management version 3
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [b0] PCI Advanced Features
                AFCap: TP+ FLR+
                AFCtrl: FLR-
                AFStatus: TP-
        Kernel driver in use: ata_piix


Debian auf Intel Desktop Board mit NM10-Chip:

root@debiantest:~# lspci -s 00:1f.2 -vvv
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 02) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Intel Corporation Device 202c
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- < PERR- INTx-
        Latency: 0
        Interrupt: pin B routed to IRQ 19
        Region 0: I/O ports at 30b8 [size=8]
        Region 1: I/O ports at 30cc [size=4]
        Region 2: I/O ports at 30b0 [size=8]
        Region 3: I/O ports at 30c8 [size=4]
        Region 4: I/O ports at 30a0 [size=16]
        Region 5: Memory at 80304000 (32-bit, non-prefetchable) [size=1]
        Capabilities: [70] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: ata_piix


Anfänglich hatte ich schon gehofft, allein durch die Umstellung von AHCI auf IDE würde ich weiterkommen :(. Je mehr ich danach such, um so sehr viel mehr Boards mit NM10 und NM70-Chip finde ich. Umso weniger verstehe ich die Einstellung der Unterstützung durch Pascom:confused:. Na ja.

Danke für die Hilfe.
Wenn ich noch etwas finde, werde ich es posten.

Schönes Wochenende
Ulf[/size][/size][/size][/size][/size][/size][/size][/size][/size][/size][/size][/size][/size][/size][/size][/size][/size][/size]

So langsam verstehe ich das Pascom-Team :o. Also bitte mein letztes Unverständnis nicht persönlich nehmen. Es wird der squeeze-Backports-Kernel benutzt und der erzeugt anscheinend diesen Fehler.

Ich habe gerade auf einem Debian Squeeze 6.0.6 das linux-image 3.2.0-0-bpo.4-686-pae installiert und es ist genau der gleiche Fehler. Allerdings fährt damit schon mal das Netzwerk hoch, so dass ich weiter suchen kann.

@Mathias: Danke für das tolle Webinar heute.

Viele Grüße
Ulf

He He :slight_smile:

musste schon lachen als die Frage kam beim Webinar vorher.
Warst Du das also :-))

Ja das mit dem Backports Kernel wusste ich auch nicht.

@Matthias: Macht immer wieder Spaß an Webinaren von Euch teilzunehmen.

Gruß Markus

Hallo zusammen,

leider muss ich berichten, dass ich aufgegeben habe :(. Während der Suche nach der Unterstützung des NM10-Chipsatzes durch den 3.2.0-0-bpo Kernel bin ich durch die Bank weg nur auf ungelöste Probleme gestoßen. Letztendlich ist es wohl der Grafik-Chip der nicht unterstützt wird.

lspci -s 00:02.0  -vvv

Mit Debian Backports konnte ich den Server zwar noch hochfahren und mich per SSH anmelden, aber der Bildschirm blieb schwarz. Eine Lösung habe ich nicht gefunden.

Aber was soll’s :D. Heute habe ich einen neuen Mini-ITX-PC mit NM70-Chipsatz bekommen und es funktioniert. Halleluja.

Im Einsatz ist ein Gigabyte GA-C1037UN mit Intel® Celeron® CPU 1037U @ 1.80GHz, 4 GB RAM, 60 GB SSD und zwei Gigabit Netzwerkkarten. Das rennt. Es ist nur ein 40mm-CPU-Lüfter verbaut, so dass das Gerät problem auch auf dem Schreibtisch betrieben werden kann. Und das Ganze gibt es fertig zusammengebaut für 230 € (in meinem Fall von Amazon). Da kann man ja nun wirklich nicht meckern, oder?

Danke an Markus und das ganze Pascom-Team für die tolle Unterstützung.

Viele Grüße
Ulf